Responsive Ads Here

Saturday, January 14, 2017

Konfigurasi DHCP Server pada MLS | Cisco Packet Tracer

Assalamu'alaikum Wr. Wb. Oke, pada kesempatan kali ini saya ingin berbagi tentang bagaimana cara konfigurasi DHCP Server pada perangkat MLS di Cisco Packet Tracer. Jadi untuk membuat DHCP Server di switch hanya bisa dilakukan di switch layer 3 saja. Dan tidak bisa di switch layer2. Oh ya sebelumnya udah pada paham DHCP kan ?? DHCP itu sebuah sistem pengalokasian/pemberian IP secara otomatis kepada client yang membutuhkan.


  • Pengertian 
  DHCP server merupakan sebuah mesin yang menjalankan layanan yang dapat "menyewakan" alamat IP dan informasi TCP/IP lainnya kepada semua client yang memintanya. Beberapa sistem operasi jaringan seperti Windows NT Server, Windows 2000 Server, Windows Server 2003, atau GNU/Linux memiliki layanan seperti ini.
  • Latar Belakang 
  Dalam metode ini, DHCP Server akan menetapkan alamat IP dari pool address (kadang-kadang juga disebut jangkauan atau ruang lingkup) untuk jangka waktu atau sewa, yang dikonfigurasi pada server sampai client memberitahu server bahwa itu tidak membutuhkan alamat lagi.

  • Maksud dan Tujuan
  Agar lebih efisien dan tidak perlu menggunakan server sebagai pengalokasian IP Addressnya. Hanya perlu beberapa konfigurasi pada router agar DHCP Server tersebut dapat berjalan.

  • Jangka Waktu 
  Jangka waktu yang diperlukan untuk konfigurasi DHCP Server pada MLS ini kurang lebih 15 sampai 30 menit hingga melakukan trouble shooting.
  • Alat dan Bahan 
  1. PC 
  2. Cisco Packet Tracer (Installed)
  • Langkah Kerja 
1. Pertama kita buat terlebih dahulu topologi jaringan dengan menggunakan Multi Layer Switch sebagai pusatnya. Dibawah ini adalah topologi jaringan yang saya buat.


2. Setelah itu kita konfigurasi terlebih dahulu vlan yang ada seperti topologi diatas.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface range fa 0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 11
% Access VLAN does not exist. Creating vlan 11
Switch(config-if-range)#exit
Switch(config)#interface range fa 0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 12
% Access VLAN does not exist. Creating vlan 12
Switch(config-if-range)#exit
Switch(config)#
3. Setelah itu kita konfigurasi IP Address untuk Vlan yang nantinya akan menjadi gateway pada setiap Client yang terhubung pada Vlan tersebut.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface vlan 11
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan11, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan11, changed state to up

Switch(config-if)#ip address 192.168.11.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 12
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan12, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan12, changed state to up

Switch(config-if)#ip address 192.168.12.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#
4. Nah setelah kita konfigurasi Vlan dan sudah mengkonfigurasi IP Address nya, kita bisa langsung konfigurasi DHCP Server. Tapi sebelum itu, saya akan sedikit menjelaskan perintah tentang konfigurasi dari DHCP Server itu sendiri.
Switch(config)#ip dhcp pool vlan11 |Perintah yang digunakan untuk mengkonfigurasi DHCP Server pada MLS maupun Router|Nama dari DHCPnya|
Switch(dhcp-config)#network 192.168.11.0 255.255.255.0 => Network yang nantinya akan disetting DHCP Server
Switch(dhcp-config)#default-router 192.168.11.1 => IP Address yang nantinya akan menjadi gateway untuk Client nya.
Setelah kalian mengerti perintah-perintahnya, langsung saja kita konfigurasi. Disini saya langsung mengkonfigurasi kedua vlan yang sudah saya setting tadi.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#ip dhcp pool vlan11
Switch(dhcp-config)#network 192.168.11.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.11.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan12
Switch(dhcp-config)#network 192.168.12.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.12.1
Switch(dhcp-config)#exit
Switch(config)#
5. Setelah itu coba kita cek dengan cara pada setiap PC Client yang terhubung kita konfigurasi DHCP Server.

Client Vlan11

Client Vlan12

6. Oke, jadi kita sudah berhasil mengkonfigurasi DHCP Server menggunakan MLS. Nah untuk mengkonfigurasi DHCP Server ini, kita juga bisa memberikan batasan IP berapa saja yang TIDAK BOLEH diberikan ke client dengan perintah
ip dhcp excluded-address <IP awal> <IP Akhir>

Switch(config)#ip dhcp excluded-address 192.168.11.10 192.168.11.20
Switch(config)#ip dhcp excluded-address 192.168.12.10 192.168.12.20

Dengan perintah diatas , maka Vlan11 tidak akan menggunakan IP Address mulai dari 192.168.11.10 sampai 192.168.11.20 dan Vlan12 tidak akan menggunakan IP Address mulai dari 192.168.12.10 sampai 192.168.12.20.
  • Kesimpulan
  Jadi untuk pengalokasian IP Address kita tidak perlu menggunakan server. Kita bisa mengkonfigurasi pada MLS ataupun pada Router seperti konfigurasi diatas. Jadi kita dapat memanfaatkan perangkat tersebut sebagai pengalokasian IP Address juga.
  • Referensi 
  1. https://help.ubuntu.com/lts/serverguide/dhcp.html
  2. http://203.130.243.185/data/eBook-CISCO/MODUL%20CISCO%20IDN.pdf

NB : Untuk konfigurasi yang lain bisa lihat DISINI

Mungkin hanya ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb.  


2 comments:

  1. makasih bro sangat bermanfaat sekelas gw pada liat blog ini

    ReplyDelete