Responsive Ads Here

Wednesday, January 4, 2017

Konfigurasi InterVlan Menggunakan Router On The Stick

Assalamu'alaikum Wr. Wb. Pada kesempatan kali ini saya ingin berbagi tentang bagaimana cara menghubungkan antar Vlan yang berbeda menggunakan Router. Oke, sebelumnnya saya sudah memposting tentang bagaimana cara menghubungkan antar Vlan yang berbeda menggunakan Multi Layer Switch, dan sekarang saya ingin menghubungkan antar vlan yang berbeda menggunakan Router.

A. Pengertian 
  InterVlan adalah cara routing yang digunakan untuk menghubungkan Vlan yang berbeda. Inter-Vlan routing membutuhkan beberapa interface fisik pada kedua router dan switch, yang lebih umum, pelaksanaan masa kini InterVlan routing tidak. Sebaliknya, beberapa izin software router mengkonfigurasi interface router sebagai link trunk, yang berarti hanya satu interface fisik yang diperlukan pada router dan switch untuk rute paket antara beberapa VLAN.

B. Latar Belakang

  Secara historis, solusi pertama untuk routing Inter-Vlan mengandalkan router dengan interface fisik beberapa. Setiap interface harus terhubung ke jaringan yang terpisah dan dikonfigurasi dengan subnet yang berbeda. 

C. Maksud dan Tujuan
 
  Agar dapat melakukan konifugurasi InterVlan dan memahami maksud dari konfigurasi tersebut. Ini bertujuan hanya untuk media pembelajaran saja pada umumnya.

D. Jangka Waktu
  Jangka waktu pelaksanaan konfigurasi InterVlan ini kurang lebih 30 menit hingga melakukan trouble shooting.

E. Alat dan Bahan

  1. PC 
  2. Cisco Packet Tracer (Installed)
F. Langkah Kerja
1. Pertama kita membuat topologinya terlebih dahulu. Nah topologi yang saya buat seperti gambar dibawah


2. Nah setelah itu kita konfigurasi vlan terlebih dahulu. Membuat vlan untuk para client. Lakukan pada kedua switch yang saling terhubung.
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fa 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
Switch(config-if)#exit
Switch(config)#interface fa 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
Switch(config-if)#exit
Switch(config)#


3. Kemudian pada kedua switch lakukan trunk pada interface yang terhubung antar kedua switch tersebut.
Switch(config)#interface fa 0/1
Switch(config-if)#switchport mode trunk

Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#exit
Switch(config)#
4. Setelah itu pada switch yang terhubung pada Router kita setting interface dengan mode trunk
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fa 0/4
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#
6. Setelah itu kita bisa konifugurasi pada routernya. Sebelumnya saya akan jelaskan tentang perintah perintahnya terlebih dahulu.
Router(config-if)#interface fa 0/0.10 = angka “10” itu adalah nomer dari vlan nya. Jadi kita akan membuat sub-interface untuk vlan 10
Router(config-subif)#encapsulation dot1q = artinya kita akan membuat jenis enkapsulasi nya menjadi 802.1q. Dia Cisco terdapat 2 jenis enkripsi yaitu ISL dan 802.1q, namun jenis ISL tidak semua perangkat support dengan enkripsi itu , jadi enkapsulasi dot1q lah yang lebih banyak dipakai.
Nah, untuk konfigurasi pada routernya kalian bisa lihat konfigurasi seperti dibawah.
 Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa 0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#interface fa 0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
% 192.168.10.0 overlaps with FastEthernet0/1.10
Router(config-subif)#exit
Router(config)#interface fa 0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
% 192.168.20.0 overlaps with FastEthernet0/1.20
Router(config-subif)#exit
Router(config)#
7. Setelah itu coba kita cek, pada setiap vlan yang berada pada router sudah memiliki gateway atau belum. Kita bisa cek dengan cara
Router(config)#do show ip interface brief
8. Nah, setelah itu kita beri IP Address pada setiap Client yang berada pada setiap vlan. Sesuaikan network untuk client dengan vlannya.

Vlan10

Vlan20

9. Nah setelah itu coba kita kirim pesan pada setiap Client yang memiliki vlan yang berbeda, Ketika mendapat keterangan "Successful" maka kita berhasil melakukan konfigurasi seperti diatas. Ketika mendapat keterangan "Failed" maka konfigurasi kalian masih ada yang salah, coba koreksi ulang salahnya.

G. Kesimpulan 
  Jadi kita dapat menghubungkan vlan yang berbeda tidak hanya menggunakan perangkat MLS. Kita juga bisa menggunakan router sebagai medianya. Hanya saja kita perlu kerja lebih untuk menggunakan router. Karena kita perlu mengkonfigurasi vlan pada switch dan kita konfigurasi InterVlan pada router juga.

H. Referensi 
  1. https://sites.google.com/site/nikiccnawiki/swithes/inter-vlanrouting
  2. http://203.130.243.185/data/eBook-CISCO/MODUL%20CISCO%20IDN.pdf

NB : Untuk konfigurasi yang lain bisa lihat DISINI

Mungkin ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb.  












No comments:

Post a Comment