About

Wednesday, January 25, 2017

Konfigurasi Routing Dynamic BGP Pada Cisco Packet Tracer

Assalamu'alaikum Wr. Wb. Pada kesempatan kali ini saya ingin berbagi tentang bagaimana cara konfigurasi Routing Dynamic BGP pada Cisco Packet Tracer. Nah pada postingan yang dulu saya sudah memposting tentang Routing Static dan beberapa Routing Dynamic seperti RIP, EIGRP, dan OSPF. Dan pada kesempatan kali ini saya meneruskan tentang konfigurasi Routing Dynamic Jenis BGP.





A. Pengertian

  Border Gateway Protocol disingkat BGP adalah inti dari protokol routing Internet. Protocol ini yang menjadi backbone dari jaringan Internet dunia. BGP adalah protokol routing inti dari Internet yg digunakan untuk melakukan pertukaran informasi routing antar jaringan. BGP dijelaskan dalam RFC 4271. RFC 4276 menjelaskan implementasi report pada BGP-4, RFC 4277 menjelaskan hasil ujicoba penggunaan BGP-4. Ia bekerja dengan cara memetakan sebuah tabel IP network yang menunjuk ke jaringan yg dapat dicapai antar Autonomous System (AS). Hal ini digambarkan sebagai sebuah protokol path vector. BGP tidak menggunakan metrik IGP (Interior Gateway Protocol) tradisional, tapi membuat routing decision berdasarkan path, network policies, dan atau ruleset. BGP versi 4 masih digunakan hingga saat ini . BGP mendukung Class Inter-Domain Routing dan menggunakan route aggregation untuk mengurangi ukuran tabel routing. sejak tahun 1994, BGP-4 telah digunakan di Internet. semua versi dibawahnya sudah tidak digunakan. BGP diciptakan untuk menggantikan protokol routing EGP yang mengizinkan routing secara tersebar sehingga tidak harus mengacu pada satu jaringan backbone saja.


B. Latar Belakang 

  Latar belakang dari kegiatan ini yaitu semisal kita ingin membuat jaringan ISP besar ataupun untuk perbankan maka dalam hal ini kita menggunakan routing BGP uuntuk  menghubungkan antar router agar saling terhubung dan saling bertukar informasi. Jadi BGP ini digunakan untuk koneksi internet antar client yang beda ISP. Kelebihan dari routing BGP iniyaitu sangat sederhana dalam instalasi.


C. Maksud dan Tujuan

  Tujuan dari kegiatan ini yaitu agar kita dapat melakukan routing dinamik BGP ini dan dapat digunakan jika kita ingin membangun sebuah ISP maupun jaringan untuk Perbankan maka routing BGP ini cocok untuk hal itu. Dalam melakukannya kita perlu teliti agar dalam melakukan konfigurasi  itu berhasil

D. Jangka Waktu

  Jangka waktu yang dibutuhkan untuk konfigurasi ini kurang lebih 30 menit dari pembuatan topologi hingga melakukan trouble shooting

E. Alat dan Bahan
  1. PC / Laptop
  2. Cisco Packet Tracer
F. Langkah Kerja

1. Pertama kita buat topologi terlebih dahulu. Disini saya membuat topologi seperti dibawah







2. Setelah membuat topologi, kita setting terlebih dahulu IP Address untuk interface pada Router. Saya setting terlebih dahulu dari yang Router 100

Router 100

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 2/0
Router(config-if)#ip address 10.10.10.1 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit
Router(config)#interface se 3/0
Router(config-if)#ip address 30.30.30.2 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#

Router 101

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 2/0
Router(config-if)#ip address 10.10.10.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 3/0
Router(config-if)#ip address 20.20.20.1 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#




Router 102

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 2/0
Router(config-if)#ip address 20.20.20.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 3/0
Router(config-if)#ip address 30.30.30.1 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#




3. Setelah itu kita konfigurasi IP Address pada PC client. Fastethernet ( Default Gateway) pada PC Client 1 Harus diisi dengan IP Fastethernet Router 100 karena PC Client 1 Terhubung secara langsung ke Router 100. Begitupun PC Client 2 dengan Router 101 , PC Client 3 dengan Router102.

PC Client 1

PC Client 2


PC Client 3

4. Setelah itu, tinggal Setting IP Routing Dynamic BGP, tapi sebelumnya saya akan menjelaskan sedikit perintah tentang konfigurasi Routing nya
Router>enable
Router#configure terminal
Router(config)#router bgp 100
Router(config-if)#neighbor<spasi>IP Router yang ingin dituju<spasi>remote-as<spasi>router bgp AS
Router(config-if)#network<spasi>IP network tujuan<spasi>mask<spasi>IP netmask tujuan
Yuk langsung saja kita konfigurasi.

Router 100
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router bgp 100
Router(config-router)#neighbor 10.10.10.2 remote-as 101
Router(config-router)#network 10.10.10.0 mask 255.255.255.252
Router(config-router)#neighbor 30.30.30.1 remote-as 102
Router(config-router)#network 30.30.30.0 mask 255.255.255.252
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#




Router 101
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router bgp 101
Router(config-router)#neighbor 10.10.10.1 remote-as 100
Router(config-router)#%BGP-5-ADJCHANGE: neighbor 10.10.10.1 Up

Router(config-router)#network 10.10.10.0 mask 255.255.255.252
Router(config-router)#neighbor 20.20.20.2 remote-as 102
Router(config-router)#network 20.20.20.0 mask 255.255.255.252
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#




Router 102

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router bgp 102
Router(config-router)#neighbor 20.20.20.1 remote-as 101
Router(config-router)#%BGP-5-ADJCHANGE: neighbor 20.20.20.1 Up

Router(config-router)#network 20.20.20.0 mask 255.255.255.252
Router(config-router)#neighbor 30.30.30.2 remote-as 100
Router(config-router)#%BGP-5-ADJCHANGE: neighbor 30.30.30.2 Up

Router(config-router)#network 30.30.30.0 mask 255.255.255.252
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#




5. Setelah itu kita coba melakukan pengujian dengan melakukan ping dan melihat jalur pada masing masing PC.



PC Client 1 ke PC Client 2


PC Client 2 ke PC Client 3 


PC Client 3 ke PC Client 1


Mengirim pesan ke setiap PC Client pada Router berbeda



G. Kesimpulan

  Jadi kita sudah berhasil melakukan konfigurasi Routing Dynamic jenis OSPF, dan ketika kita melakukan touring pada Cisco Packet Tracer kita bisa lihat jalur mana saja yang dilalui untuk berkomunikasi dengan cara "tracert"


H. Referensi
  1. https://id.wikipedia.org/wiki/Border_Gateway_Protocol



NB : Untuk konfigurasi yang lain bisa lihat DISINI


Mungkin hanya ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb.


Faiz Ahmad

About Faiz Ahmad

Faiz Ahmad. Salatiga, 28 Juni 2000. Saya hanya seorang Hamba Allah yang masih banyak kekurangan, maka dari itu saya ingin menutupi kekurangan saya dengan melakukan hal yang bermanfaat kepada orang lain. Seperti filosofi tanah “Bermanfaat untuk orang sebanyak mungkin, namun dikenal oleh orang sesedikit mungkin”. Pernahkah kita mengingat jasa tanah? Sedetik saja dalam sehari? Saya rasa hanya sedikit sekali yang mengingatnya, berbeda dengan matahari yang jasanya selalu kita ingat. Padahal kita semua tentu tahu bagaimana jadinya dunia ini jika tidak ada tanah.

Subscribe to this Blog via Email :