About

Friday, January 13, 2017

Konfigurasi Routing EIGRP Pada Cisco Packet Tracer

Assalamu'alaikum Wr. Wb. pada kesempatan kali ini saya ingin berbagi tentang bagaimana cara konfigurasi Routing Dynamic jenis EIGRP pada Cisco Packet Tracer. Nah sebelum itu saya akan membahas terlebih dahulu tentang EIGRP ini.


  • Pengertian 
   Enhanced Interior Gateway Routing Protocol (EIGRP) adalah lanjutan jarak-vector routing protokol yang digunakan pada jaringan komputer untuk mengotomatisasi routing yang keputusan dan konfigurasi. Protokol ini dirancang oleh Cisco Systems sebagai protokol proprietary, hanya tersedia pada router Cisco. Fungsi parsial dari EIGRP dikonversi menjadi sebuah standar terbuka pada tahun 2013 dan diterbitkan dengan statusnya informasi sebagai RFC 7868 pada tahun 2016.
EIGRP digunakan pada router untuk berbagi rute dengan router lain dalam sama sistem otonom . Tidak seperti protokol routing lain terkenal, seperti RIP , EIGRP hanya mengirim update inkremental, mengurangi beban kerja pada router dan jumlah data yang perlu dikirimkan.



EIGRP mendukung fitur berikut: 

  • Dukungan untuk Classless Inter-Domain Routing (CIDR) dan variabel panjang subnet masking. Rute tidak diringkas pada batas jaringan classful kecuali Ringkasan auto diaktifkan.
  • Dukungan untuk load balancing link paralel antara situs.
  • Kemampuan untuk menggunakan password otentikasi yang berbeda pada waktu yang berbeda.
  • MD5 otentikasi antara dua router.
  • Mengirimkan perubahan topologi, daripada mengirim seluruh tabel routing ketika rute berubah.
  • Berkala memeriksa apakah sebuah rute yang tersedia dan merambat perubahan routing untuk router tetangga jika ada perubahan yang terjadi.
  • Berjalan terpisah routing yang proses untuk Internet Protocol (IP), IPv6 , IPX dan AppleTalk melalui penggunaan modul protokol-dependent (PDM).
  • Kompatibilitas mundur dengan protokol IGRP routing. 

  • Latar Belakang 
  Saya ingin mempelajari karena Routing EIGRP mengkombinasikan kelebihan-kelebihan yang dimiliki oleh protokol routing link-state dan distance vector. Tetapi pada dasarnya EIGRP adalah protokol distance vector karena router-router yang menjalankan EIGRP tidak mengetahui road map/ topologi network secara menyeluruh seperti pada protokol link-state.
  • Maksud dan Tujuan  
Menggabungkan network yang berbeda dengan cara :
A. Memilih jalur/route untuk mencapai suatu network dengan ongkos paling rendah, dan bebas looping.
B. AD (advertised distance), menggambarkan seberapa jauh sebuah network dari neighbor, merupakan ongkos (metric) antara router next-hop dengan network destination.

C. FD (feasible distance), menggambarkan seberapa jauh sebuah network dari router, merupakan ongkos (metric) antara router dengan router next-hop ditambah dengan AD dari router next-hop.
  • Jangka Waktu
  Jangka waktu yang dibutuhkan untuk konfigurasi pada Cisco Packet Tracer ini kurang lebih satu jam hingga melakukan trouble shooting.
  • Alat dan Bahan 
  1. PC 
  2. Cisco Packet Tracer (Installed)
  • Langkah Kerja
1. Pertama kita buat topologi terlebih dahulu, topologi yang saya buat  seperti gambar dibawah.





2. Setelah kita membuat topologinya, kita bisa langsung konfigurasi. Nah agar mudah kita konfigurasi IP Address terlebih dahulu Routernya. dan router yang saya konfigurasi adalah router 1 terlebih dahulu.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface se 2/0
Router(config-if)#ip address 12.12.12.2 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit
Router(config)#interface se 3/0
Router(config-if)#ip address 10.10.10.1 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#



 3. Setelah kita melakukan konfigurasi IP Address pada router 1, maka kita akan konfigurasi router selanjutnya yaitu router 2. Nah konfigurasi bisa lihat dibawah.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface se 3/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#interface se 2/0
Router(config-if)#ip address 12.12.12.1 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

4. Setelah kita selesai melakukan konfigurasi IP Address pada router 1 dan router 2, kita konfigurasi router 3.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface se 3/0
Router(config-if)#ip address 10.10.10.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#interface se 2/0
Router(config-if)#ip address 11.11.11.1 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#
5. Kemudian kita udah mengkonfigurasi IP Address pada setiap router. Agar memudahkn kita lagi langsung saja kita konfigurasi Routing Dynamic nya. Nah untuk perintah pada saat routing dynamic akan saya jelaskan dibawah.
Router(config)#router eigrp 10 => | Jenis routing nya | AS Number
Router(config-router)#network 10.10.10.0 => Network dari salah satu interface yang terhubung
Nah langsung saja kita konfigurasi Routing EIGRP pada router 1. Perintahnya seperti dibawah.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 10
Router(config-router)#network 10.10.10.0
Router(config-router)#network 12.12.12.0
Router(config-router)#network 192.168.1.0
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

6. Nah setelah kita melakukan routing EIGRP Pada router 1 maka kita lanjutkan pada router 2. Caranya sama seperti diatas
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 10
Router(config-router)#network 11.11.11.0
Router(config-router)#network 12.12.12.0
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#


7. Nah setelah kita melakukan konfigurasi pada Router 1 dan Router 2 maka kita konfigurasi juga pada router 3, nah untuk konfigurasinya sama seperti diatas.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 10
Router(config-router)#network 10.10.10.0
Router(config-router)#network 11.11.11.0
Router(config-router)#network 192.168.3.0
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration...
[OK]
Router#

8. Nah setelah kita konfigurasi IP Address pada router dan kita konfigurasi Routing EIGRP nya maka kita lakukan konfigurasi IP Address pada setiap Client dan pastikan sesuai dengan subnet yang telah ditentukan oleh router tadi.

Client router 1

Client router 2

Client router 3

9. Nah setelah itu kita coba mengirim pesan antar client yang berbeda router untuk mencoba apakah routing tersebut sudah success atau belum.

Nah ketika mendapatkan keterangan "Successful" maka kita berhasil melakukan konfigurasi pada Routingnya. Sedangkan ketika mendapatkan keterangan "Failed" maka cek lagi. kemuingkinan masih terdapat kesalahan pada saat konfigurasi IP Address.

  • Kesimpulan 
  Jadi Routing EIGRP ini mudah, tetapi jika kasus topologinya berbeda kita harus mampu menentukan router manakah yang harus melakukan Routing EIGRP sesuai dengan yang dibutuhkan.



NB : Untuk konfigurasi yang lain bisa lihat DISINI

Mungkin hanya ini yang bisa saya bagikan. Sekian.
Assalamu'alaikum Wr. Wb. 

Faiz Ahmad

About Faiz Ahmad

Faiz Ahmad. Salatiga, 28 Juni 2000. Saya hanya seorang Hamba Allah yang masih banyak kekurangan, maka dari itu saya ingin menutupi kekurangan saya dengan melakukan hal yang bermanfaat kepada orang lain. Seperti filosofi tanah “Bermanfaat untuk orang sebanyak mungkin, namun dikenal oleh orang sesedikit mungkin”. Pernahkah kita mengingat jasa tanah? Sedetik saja dalam sehari? Saya rasa hanya sedikit sekali yang mengingatnya, berbeda dengan matahari yang jasanya selalu kita ingat. Padahal kita semua tentu tahu bagaimana jadinya dunia ini jika tidak ada tanah.

Subscribe to this Blog via Email :